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ECP PASSTHRU OVERVIEW

CellComEX Universal Communicators enable you to take over and manage ECP panels with connection to
the ECP Bus. This feature is called ECP Passthru.

This guide is designed to walk you through ECP passthru installation and setup. For more complete
information on CellComEX setup, refer to the CellComEX Installation and Programming Guide (LT-2663).

@ Procedure

The installation must follow this procedure:

Step 1: Mount the communicator.

Step 2: Wire the communicator.

Step 3: Program Vista keypad device address 20
Step 4: Configure ECP settings (remotely or locally)
Step 5: Changing Programming

Required Materials
The following software and hardware components are required to ensure successful system takeovers:

e Compatible Honeywell VISTA panel (refer to “VISTA Panel Compatibility™)

¢ Connection to Dealer Admin (for programming)
e 18-22 AWG unshielded wire (RYGB)

¢  Remote Link minimum Version 2.21
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Figure 1: CellComEX Components
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https://www.dmp.com/assets/LT-2663.pdf

STEP 1: MOUNT THE COMMUNICATOR

The module comes in a high-impact plastic housing that you can mount directly to a wall, backboard, or
other flat surface.

For easy installation, the back and ends of the CellComEX housing have wire entrances. The back also
contains multiple mounting holes that allow you to mount the module on a single-gang switch box.

Remove the PCB from the plastic housing by loosening the clips on one side and gently lifting it out of the
housing base.

Insert the included screws in the desired mounting hole locations and tighten them to secure the housing to
the surface.

Reinstall the PCB in the housing base.

STEP 2: WIRE THE COMMUNICATOR

The communicator can be connected to the ECP Bus of a VISTA panel. See Table 1 and Figure 2 for the
necessary wiring connections.

Caution: Remove all AC and battery power from the control panel before wiring.

1. Attach the antenna to the SMA connector. Refer to Figure 1.

2. Make sure the Vista panel has batteries connected to the system and is also connected to an appropriate
power supply.

3. Connect the communicator to Dealer Admin or Remote Link.

Communicator to ECP Wiring

Com Series | ECP Bus Typical Color
+DC Keypad Power | Red

-DC GND Black

Z+ Data Out Yellow

Z- Data In Green

Table 1: Wire Connections
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Figure 2: ECP Wiring
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STEP 3: PROGRAM THE VISTA KEYPAD

In this step, you will program VISTA Keypad 5 Device Address 20. This enables the VISTA panel to
communicate with a CellComEX. This step must be performed locally at the VISTA panel.

1.

2.

To save and exit programming, enter *99.

CELLCOMEX SERIES HOW-TO GUIDE: ECP PASSTHRU |

Power down and then power up the VISTA panel.
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Within 1T minute of powering up the VISTA panel, simultaneously press and hold the # and * buttons on
the Vista keypad.

The keypad displays INSTALLER CODE. Enter the installer code (default is 4112), followed by 8 O O.
Enter *193, then enter 1 0.



STEP 4: CONFIGURE ECP SETTINGS

For the communicator to properly process data from the VISTA panel, keypad input must be set to ECP. You
can perform this programming remotely with Dealer Admin.

Why is this important? Dealer Admin configures the CellComEX to receive ECP data.

Remotely (Dealer Admin)
Before programming, ensure the ECP panel’s IP address is set as default.

—_

Go to Customers.
2. Find and select the system name.

3. Go to Programming > System Options.

4% In Keypad Input, select ECP.

5° In ECP Partition, enter the number of the partition where you want the communicator to operate.
6.° Press Begin ECP Setup.

7.° If the host panel is a VISTA 128, turn on VISTA 128.

8.° Enter the host panel’s installer code in VISTA Installer Code.

9° Press Begin.

(]
10. After setup is complete, Dealer Admin automatically retrieves zones from the host panel. If you need to
retrieve zones again later, open System Options and select Get Zones.

System Options Cross Zone Time [
ECP Setup

o VISTA 1287
0 VISTA Installer Code

Power Fail Delay
Swinger Bypass Trips
Reset Swinger Bypass

Time Change . e
Begin J

Hours from GMT L

o Keypad Input ECP -

e ECP Partition 1 -

Weather Zip Code 00000

Adding User 2
1. At USER NUMBER, enter 2.

At CODE NO, enter the code from the Vista panel’s User 2.
At USER NAME, enter MASTER.
At MASTER? select the checkbox.

GRS

Press Send.
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STEP 5: CHANGING PROGRAMMING
Option 1: Programming with Host Keypad

If you have access to the host panel, you can make zone programming changes in the panel locally using
a host keypad. To retrieve new zone programming, select Get Zones in the System Options tab in Dealer
Admin.

Option 2: Programming using Compass and Remote Link

Starting with Remote Link™ Version 2.21, you can connect a customer’s Honeywell VISTA® panel with
CellComEX communicators using Honeywell’s Compass® software and Remote Link.

Why is this important? Remote Link is necessary if programming using Compass. It provides a link
between the CellComEX and the host panel. Without doing this, no new programming (zones, devices, etc.)
can be sent to or retrieved from the host panel.

The following instructions assume that you already have the CellComEX added with the appropriate
connection information in Remote Link. To enable ECP Passthru for that account, complete the following
steps.

—_

Right-click Remote Link and select Run as administrator.

2. Double-click the communicator account to open it.

3. Go to Program > System Options.

4. To enable communication, go to Keypad input and select ECP. Press OK.
5. Go to File > Panel Information.

6° In Connection Information, enter the VISTA account number in Ecp Acct.
7.° Press OK.

8° Go to ECP Passthru > ECP Start/Stop Server.

9° Press Yes when asked if ECP Passthru should be started.

10. Minimize Remote Link.

2 e e | v e s It e

1 1o XRS50 192 Region [Hortheast |
1 12355 DualCom 192 '.: Remote Link : [1-12355] 12355
1 234 XTL 192 Connection Information File System Panel Program | Ecp Passthru Language Window Help
1 32154 XTS0 192 Type |N°lw°ﬂ‘ ﬂ § Panel Information Close Pa+ Ecp Start/Stop server t:unnect Diagnostics
1 44733 XRS50 191
abc123 Ecp PassthruLog  Alt+F12

1 55667  XRSS0 193 Remote Key | ‘ I

P Address |192‘wss.n‘1|

P Port 2001

e EcpAcct 3 3005

—Backup Connection Information

e T -l
Confirm e *
— . =
Location W% Ecp passthru Server is not running.
Address [ . & 4
| Do you want to start it?
City |Bostun
v || staterzip 1A
’ Voice Phone
Delete Archive | Night Phone
Extra Information
_J Export ‘ ‘ System Info | OK | Cancel |
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Add the VISTA Panel in Compass

1. Open Compass.

2. In the lower right corner of the Customers page, select Add. The Customer Detail window opens.
3" In Subscriber Data, enter a Receiver number and Account number.

4% In the Panel Data section, select the VISTA panel model and revision number.

5° In Network Device MAC Addr, enter FFFFFF.

6. Press OK.

Subscriber Data
Receiver Account Last Name First Name
3 1 1234
Business Voice Phone Fax
Address 1 Address 2
City State Zip Code Zip Ext
user_field_1 user_field_2
Panel Data bicile= B
Panel Revision e
|vistatsp ~| |vistatsp-9 =
Class Panel Phone Number
CallerID — | EEProm
CallerlD ;
Firmmware =
IP Communication Device y i — ’ 1
\ " o Mass Download Job Name | lone T
Network Device MAC Addr. 000020 + [ FFFFFF
S
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Set Up Communication in Compass
1. In Customers, double-click the account that you created in the previous section.

The Panel Editor opens. Go to Tools > Communications.
Go to File > Communication Settings.
Select TCPIP Port Settings.

Press Add.
Back in Communication Settings window, select Apply.

2
3
4
5° To ensure that Compass uses a TCP/IP connection, select a TCP/IP port.
6
7
8. Press OK.

%4 Communication Settings = 3 Configure TCPIP Port | 2 |
-Select Company
Select TCPIP Part for Compass ©
IAdemco.-"First Alert b l
[TePiP ~] sdd | Delete

~Modem Settings

Select COM ports I vl LConfigure COM ports
IP Address I

Standard Modems : Custom Modems : [Eantral Server)

Intemet  Intranet Contraller

<Maone

Ademco Cla 2400

Hayes Accura 144 V4.0

Hayes Optima 336 Esxternal

Hayes Optima SMARTMODER 2400
Haypes Smartmodem 1200

AR ]

Yiew | aad | Edi | Delte | Deeten | ’

[ Touch Tone Dial Out Prefix |
[ SpeakerOn

Modem Yol I vl
[T Off After Cornect SRSIAIEIS. |

0 TCPIP Port Settings... | 0 ok | LCancel | oA

AlarmMeti Website Icontrolsewer.alarmnet.com Ok Cancel

] »

- | 1 ] 3

pply |
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Configure TCP/IP Settings in Compass

1. In the lower left corner of the Compass Communication window, press Connect.

2. A dialog pops up to notify you that communication settings must be configured. Press OK.
3. Select Enable TCP/IP.

In the TCPIP Port dropdown, select the appropriate TCP/IP port.

5° Ensure that the Network Device MAC Addr is FFFFFF.

6. In Connection Mode, select ECP.

7.° Ensure that AlarmNet-i is selected.

8° Press Connect.

[ [ = ]

% Communications J

- TCPIP Port
| TCPIP 1 =]

— Cotinection Detail

* Use Account CSID

™ Firgt Time Cammunication

e W &cct#in Panel
W Enable TCRAF
Metwork Device MAC Addr |DEIDEI2D = "FFFFFF E Save | Undo

Connection Mode

ECP hd

(& AlarmMet ™ Private LAN

Retrieving Zones in Dealer Admin

After programming in Compass is completed, navigate to the System Options tab in Dealer Admin and press
Get Zones. This ensures any new programming can be viewed in Virtual Keypad and Dealer Admin.
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REFERENCE

Virtual Keypad

Virtual Keypad enables users to manage their systems remotely, including arming, disarming, viewing zone
status, bypassing zones, viewing history, managing users, and more. Virtual Keypad has not been evaluated
by Intertek.

To use Virtual Keypad for remote management, the configuration must meet the following conditions:

« ECP Panels must be programmed as Stay/Away for remote arming and disarming (No Partitions).

e User 2 in the CellComEX must match user 2 in the Vista panel and be used when logging into Virtual
Keypad to remotely manage the Vista panel.

HYOUR LOGO
swiTCH svsTEM »
O armine ZONE STATUS ARMING / HISTORY
CURESIATES BUSINESS
8 voeo © Arming ZONE STATUS () History
A
@ isTory (&) 7:59 A FRONT DOOR Uriocked by JORDAN JON
Ny
Y FAvoRTES L=pe] { () 746AM Al System Off - Disarmed
Stay. () 7:45AM BACK DOOR Lock
STAY AWAY Qoo
O rasam s
8 THERMOSTATS
() 7:45AM BACK DOOR Accessed b
Disarmed Q ueHTS
seneouies EuR 5 Lockoom:  arace000R | + ook | O Rermesk
(&) HISTORY VIEW ALL A (s
L") 7:59 AM FRONT DOOR Unlocked by o users & &
JORDAN JONES
E3 PROFILES ACCESS A
L'} 7:46 AM All System Off - Disarmed by -
JORDAN JONES [
£\ NoTFicaTIONS
Q) 7:45 AM BACK DOOR Locked

| Vo |
=
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VISTA Panel Compatibility

Panel Type

VISTA-10SE

VISTA-10P

VISTA-15

VISTA-15P

VISTA-20SE

VISTA-20P

VISTA-20PI

VISTA-21iP

VISTA-21iPLTE

ECP Remote
Rev 15 or higher No
Yes Yes
Yes No
Yes Yes
Rev 12 or higher No
Yes Yes
Yes Yes
Yes Yes
Yes Yes

Remote

User Management Arming/Disarming

No

Yes

No

Yes

No

Yes

Yes

Yes

Yes

Remote

No

Yes

No

Yes

No

Yes

Yes

Yes

Yes

Zone Status

a Note: Vista 32, 40, 50, 128, 250 are not compatible with ECP Virtual Keypad and eSuite.

Designed, engineered, and
manufactured in Springfield, MO

using U. S. and global components.

LT-2689 22355
© 2025

INTRUSION -

FIRE -

ACCESS

Compatible with
Compass

No

Firmware version
2.0 or higher

No

Firmware version
5.2 or higher

No

Firmware version
5.2 or higher

Firmware version
5.0 or higher

Yes

Yes

e NETWORKS

2500 North Partnership Boulevard
Springfield, Missouri 65803-8877

800.641.4282 | DMP. com
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